February 16, 2009

Movable Type 4.1 から 4.23 へ

Movable Type をアップグレード

Movable Type においてクロスサイトスクリプティングによる脆弱性が確認されました。この問題に対処するため、Movable Type の修正バージョンを公開致します。脆弱性の修正バージョンとなりますので、アップデートを推奨致します。

本当は去年の暮れにやろうと思ったんですが、気がついたら年が明けて1ヶ月半も経ってしまいました。クロスサイトスクリプティングによる脆弱性、と言われてもあまりピンときませんが、Movable Type の再構築にかかる処理速度が変わったみたいだったので、この際にアップグレードしました。

アップグレードするにあたって、『小粋空間』さんを参考にしました。

アップグレードしたんだけども・・・ バージョン情報が

photo_090216_04.jpg

Movable Type のシステムメニューのツールのシステム情報で確認するとバージョンが4.1と表示されています。なんでだろう・・・。

アップグレードしたんだけども・・・ InsertLink

つい最近入れたプラグインなんですが、MT4.23にアップグレードしたら機能しなくなりました。詳しく調べていないのでわかりませんけれども、僕の場合はうまく対応できていないようです。